[Openmcl-devel] Cross-compile CCL - ARMv7

Gary Byers gb at clozure.com
Thu Oct 8 18:48:26 UTC 2015


I assume that you are using some version of an unnamed ARM cross-compiler
on an unnamed host to cross-compile the CCL kernel, and getting a 
segmentation
fault somewhere when you try to run the code that code on an ARM machine.

People who maintain the cross-compiler that you are using might know,  They
would likely have more of an idea than I do.


On 10/08/2015 05:53 AM, Pilar Gil Jaldo wrote:
>
> Hello CCLs!
>
>
> I´m trying to cross compile CCL for following architecture:
>
> CCL version 1.11
>
> Cyclone V – armv7
>
> Using openwrt
>
> I have tried to compile directly from the target and in this case 
> everything works fine. I just introduce „make clean“ and „make“ and I 
> can launch ccl without problems.
>
> The problem comes when I try to the the same from my host, setting 
> before the path where the toolchain and algo where gcc and as are placed.
>
> I can cross compile CCL but when I run it in my target ….“Segmentation 
> fault“
>
> Do maybe one of you have a clue about how to cross-compile CCL ?? Am I 
> missing something important??
>
> Any kind of help will be nice =)
>
> Pilar
>
>
>
> _______________________________________________
> Openmcl-devel mailing list
> Openmcl-devel at clozure.com
> https://lists.clozure.com/mailman/listinfo/openmcl-devel

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clozure.com/pipermail/openmcl-devel/attachments/20151008/cc2b68a4/attachment.html>


More information about the Openmcl-devel mailing list