[Openmcl-devel] Clozure CL is healthy?

Ron Garret ron at flownet.com
Wed Sep 1 11:19:47 PDT 2021

On Sep 1, 2021, at 10:46 AM, Myra Jean Prelle <mjp32 at comcast.net> wrote:

> Hi CCl folks
> I tried following the instructions from:  https://github.com/Clozure/ccl/releases
> but I’m having a problem:
> kumquat-2:lisp_ccl myra$ git clone https://github.com/Clozure/ccl.git ccl-dev
> Cloning into 'ccl-dev'...
> remote: Enumerating objects: 31789, done.
> remote: Counting objects: 100% (138/138), done.
> remote: Compressing objects: 100% (108/108), done.
> remote: Total 31789 (delta 59), reused 67 (delta 30), pack-reused 31651
> Receiving objects: 100% (31789/31789), 46.11 MiB | 47.03 MiB/s, done.
> Resolving deltas: 100% (22959/22959), done.
> kumquat-2:lisp_ccl myra$ 
> kumquat-2:lisp_ccl myra$ curl -L -O https://github.com/Clozure/ccl/releases/download/v1.12/darwinx86.tar.gz
>   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
>                                  Dload  Upload   Total   Spent    Left  Speed
>   0     0    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
> curl: (7) Failed to connect to github.com port 443: Bad file descriptor
> kumquat-2:lisp_ccl myra$ 

The process failed at this point: "curl: (7) Failed to connect to github.com port 443: Bad file descriptor”

> I looked in the ccl_dev directory, & there are a lot of good things there.  But 
> kumquat-2:ccl-dev myra$ tar xf ../darwinx86.tar.gz
> tar: Error opening archive: Failed to open '../darwinx86.tar.gz'

Yes, that is not surprising.  The darwinx86.tar.gz does not exist because you failed to retrieve it in the previous step.  So that’s what you need to debug.  You can check if you have successfully retrieved the file using ls.

Now, it is not immediately obvious why that step failed, only that it failed.  The command you have there works for me.  So the first thing I would do is simply try it again.  It might have been a temporary problem at github.

But I can see another problem that you would have had even if this step had worked.  You are retrieving darwinx86.tar.gz into the current directory (i.e. into lisp_ccl) but trying to unpack it in the parent directory (the double-dot).  That probably won’t work.  You probably want just:

tar xzf darwinx86.tar.gz

(Throwing the z flag in to tell tar that the file is compressed shouldn’t be necessary, but it can’t hurt.)


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.clozure.com/pipermail/openmcl-devel/attachments/20210901/a6d60e11/attachment.htm>

More information about the Openmcl-devel mailing list